summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..be11c85
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.13)
+project(ur-sfml)
+set(CMAKE_CXX_STANDARD 20)
+set(EXECUTABLE_NAME ur)
+
+# setup SFML
+set(SFML_LIBRARIES sfml-system sfml-window sfml-graphics)
+find_package(SFML 2.5 REQUIRED COMPONENTS system window graphics)
+
+add_executable(${EXECUTABLE_NAME} ur.cpp helper.h helper.cpp)
+target_link_libraries(${EXECUTABLE_NAME} ${SFML_LIBRARIES})
+
+file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/res DESTINATION ${CMAKE_CURRENT_BINARY_DIR})