summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Enders <smenders@gmail.com>2021-01-23 11:52:32 -0500
committerStephen Enders <smenders@gmail.com>2021-01-23 11:52:32 -0500
commita408a43cd105b89a8d44292e2ef69802a5660497 (patch)
treea70ce8c54f57c2f6f2a8603b9e45d352cc5bc083 /CMakeLists.txt
parentf01537a8ff454b68b83574f16cb4e2ff244a4e8a (diff)
Move source files to src folder
We'll be making a few source files it'll be useful to have them organized at least somewhat from our non-src files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 683ead2..9aa3965 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@ set(EXECUTABLE_NAME ur)
set(SFML_LIBRARIES sfml-system sfml-window sfml-graphics)
find_package(SFML 2.5 REQUIRED COMPONENTS system window graphics)
-add_executable(${EXECUTABLE_NAME} ur.cpp helper.cpp timedLatch.cpp random.cpp)
+add_executable(${EXECUTABLE_NAME}
+ src/ur.cpp
+ src/helper.cpp
+ src/timedLatch.cpp
+ src/random.cpp)
target_link_libraries(${EXECUTABLE_NAME} ${SFML_LIBRARIES})
file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/res DESTINATION ${CMAKE_CURRENT_BINARY_DIR})