summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Enders <smenders@gmail.com>2021-01-29 20:42:36 -0500
committerStephen Enders <smenders@gmail.com>2021-01-29 21:25:35 -0500
commit9282acbacda6e6c67d9f2cde8ba5511216b7d3b0 (patch)
treea35c8e9e2ba753a4aa7a7bb48f16aba30b60f141 /CMakeLists.txt
parent931dd28838fe09e8e8f07889f7a23c88aa47785b (diff)
Add windows and linux build notes
Added some really rough build notes too
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9aa3965..96ac035 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,11 @@ project(ur-sfml)
set(CMAKE_CXX_STANDARD 20)
set(EXECUTABLE_NAME ur)
+# detect windows
+if (WIN32)
+ set(SFML_DIR /home/senders/Downloads/SFML-2.5.1/lib/cmake/SFML)
+endif()
+
# setup SFML
set(SFML_LIBRARIES sfml-system sfml-window sfml-graphics)
find_package(SFML 2.5 REQUIRED COMPONENTS system window graphics)