summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSteph Enders <smenders@gmail.com>2022-06-17 11:19:51 -0400
committerSteph Enders <smenders@gmail.com>2022-06-17 11:19:51 -0400
commit87a53f2a09a204ca9bcdde9c73db414c79075326 (patch)
tree5dbb78e554d01a8f9dd1e3cdf11d4077f0d15676 /CMakeLists.txt
parent49bb775d4cf9935b0f0d54daa358423ac786c9be (diff)
Add scene controls and win/loss scenarios
Setup ability to check collisions and transition game scene
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3dcce6a..bb5735d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,5 +17,5 @@ find_package(SFML 2.5 REQUIRED COMPONENTS system window graphics)
#file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/maps DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
#file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/include DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
-add_executable(${PROJECT_NAME} src/main.cpp src/Level.cpp src/Level.h src/Api.h)
+add_executable(${PROJECT_NAME} src/main.cpp src/Level.cpp src/Level.h src/CApi.h src/Scene.h src/LuaApi.h)
target_link_libraries(${PROJECT_NAME} ${LUA_LIBRARIES} ${SFML_LIBRARIES})