summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBill <bill@billserver.senders.io>2022-06-17 20:26:20 -0400
committerBill <bill@billserver.senders.io>2022-06-17 20:26:20 -0400
commit3811dc139a32bf1f2a164f770ee172f07139f76d (patch)
tree1905e3bfafdacb57a341088898ca96826b9fd970 /CMakeLists.txt
parent7d1b2c96780f2ffb08a97420fac2794a264c764d (diff)
Setup so it can build on debianbill-build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f134e83..a4d100b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.20)
+cmake_minimum_required(VERSION 3.0)
project(dng)
set(CMAKE_CXX_STANDARD 20)
@@ -7,8 +7,10 @@ find_package(Lua REQUIRED)
# check what features I use and assert minimum
if (LUA_VERSION_STRING VERSION_LESS "5.4")
- message(FATAL_ERROR "Invalid Lau version: ${LUA_VERSION_STRING} - must be >= 5.4")
+ message(FATAL_ERROR "Invalid Lau version: ${LUA_VERSION_STRING} - must be >= 5.4")
endif()
+include_directories(${LUA_INCLUDE_DIR})
+
#set(SFML_LIBRARIES sfml-system sfml-window sfml-graphics)
#find_package(SFML 2.5 REQUIRED COMPONENTS system window graphics)